共用サーバはリスク高い [2008/08/01]

共用サーバは安くていいけど、リスクも高い。
それを承知で使わなくてはならない。もちろん良質なものもあるが。
以下実際に直面したこと。

■パフォーマンスの低下
MovableTypeでログインするのに数分かかるくらい、パフォーマンスが低下した。

■バッチエラー
少し負荷のかかるバッチ処理は全部エラーになった。

■PHPの設定が変わっていた
知らぬ間にregister_globals とかパラメータが変わっていた。

■PHPがバージョンアップされていた
知らぬ間にPHP4 ⇒ PHP5 に変わっていた。
PHP4用に作ったプログラムは当然動作せず。

やはり最低限VPSは必要か。